Derby's FowardCompatibility goal is to allow any application written against the public interfaces of an older version of Derby to run, without any changes, against a newer version of Derby. Any incompatible changes should be a conscious decision and be recorded in Jira with the "Existing Application Impact" checkbox.

To verify this is true for the 10.4.2 release and to help ensure you don't have problems running after the release, please test applications that use Derby and make sure we have provided as seamless an upgrade as possible for existing applications. Try your own application or some other application that uses Derby. Be sure to read the release notes; they document each issue where it was considered necessary to make an incompatible change with a dedicated Release Note.

Table of Contents

Contents

  1. Testing Ideas

Testing Ideas

Test your favorite application with Derby 10.4.2. See Derby Resources, WorkingWithDerby and UsesOfDerby for more possibilities.

Name of Application

Build Tested

Tests Performed

Tester

Bugs Filed

Comments

-

-

-

-

-

-

TenFourTwoApplicationTesting (last edited 2009-09-20 22:12:04 by localhost)