Q. On Linux I'm getting the following error messages: No supported regular expression matcher found, or Eclipse compiler class for Ant could not be found. All requried jars (ant-apache-oro.jar, ecj_3.2.jar, etc) are in place at $ANT_HOME/lib. What should I do?

A. If you have ant installed from rpm package, it has a priority over $ANT_HOME/bin/ant, see http://www.jayasoft.org/node/820. The problem happens because $ANT_HOME/bin/ant reads /etc/ant.conf which sets rpm_mode=true unless --noconfig is set. Supplying --noconfig option solves the problem.

ANT_FAQ (last edited 2009-09-20 21:54:24 by localhost)