Differences between revisions 10 and 11
Revision 10 as of 2009-01-03 00:38:03
Size: 2209
Editor: wrowe
Comment: bring these docs up to date with installer and apachemonitor changes
Revision 11 as of 2009-09-20 22:13:29
Size: 2209
Editor: localhost
Comment: converted to 1.6 markup
No differences found!

Here follow specific quirks that are encountered on Windows Vista/Longhorn. For general information about these and all other flavors of Microsoft Windows and Apache HTTP Server see the main WindowsPlatform wiki page instead.

known bug - ApacheMonitor

Prior to 2.2.8 and 2.0.63, the taskbar icon applet ApacheMonitor, which displays a feather and the state of the installed apache services, had issues on Vista. After the patches, the current flavor of ApacheMonitor will confront you with a dialog to Run As Administrator if you want to start/stop the service and need additional credentials. Sadly the icon will shift all the way to the left when you do this, but you won't need to answer the dialog again if you are starting and stopping multiple services, or if you will be stopping and starting the server repeatedly.

known issue - Apache MSI doesn't create configuration files or install Apache Service

Prior to 2.2.8 and 2.0.63, when User Account Control (UAC) is switched on (which it is by default), running the Apache MSI installer threw up various errors about creating configuration files and then complained that it can't install or start the Apache service.

These issues went away if UAC is turned off. After the installation has completed, UAC can be turned back on and the Apache service can still be stopped/started.

In the current versions, these files are installed successfully. But to modify the config that is located in c:\program files[ (x86)]\apache software foundation\apache2.2\conf, you will have to *really* be administrator. E.g. right click on the Command Prompt icon and choose 'Run as Administrator', then notepad to your heart's content.

known issue - Apache Service won't install

Running httpd.exe -k install doesn't install the service.

Workarounds are to run the command prompt with administator privileges, or use the runas command to run that command line as an administrative user, or set the "Run as administrator" flag on the Compatibility tab of the Properties of httpd.exe. See above for notes to run the Command Prompt as administrator.

WindowsVistaPlatform (last edited 2009-09-20 22:13:29 by localhost)