There is a proposal for JMeter to require at least Java 1.4.

This has now been agreed; JMeter now requires at least Java 1.4

This gives the opportunity to make some changes and improvements.

JDBC Pooling

Regular Expressions

ORO works well - is there any point moving to java regular expressions?

Java REs allow look-behind matching; however there are some concerns about the way it treats line-endings. It appears that the line-endings can vary between Host OSes; this is not really suitable for JMeter.

Miscellaneous features

Remove work-rounds for the following:

Allow the use of the following:

Additional Exceptions

Chained Exceptions

Probably not worth using

Java14Proposals (last edited 2009-09-20 21:56:23 by localhost)