Upgrading Struts 1.0 to Struts 1.2.x

Struts observes a careful deprecate-release-remove cycle between each release series. If you you skip releases and try to go from 1.0 to 1.2, you'll miss two series of deprecations and removals (1.0. to 1.1 and 1.1 to 1.2). Once the code is removed, the deprecation warning disappears, and you end up with "missing link" code.

It might be worthwhile to upgrade one release at a time, and respond to any deprecation warnings on one release series (1.1) before moving on to the next (1.2).

However, if you intend to make the jump directly from 1.0 to 1.2, the following notes may help.

jars

tlds

validator

StrutsUpgradeNotes10to12 (last edited 2009-09-20 23:12:14 by localhost)