Eclipse

Eclipse is an excellent IDE for writing your Tapestry applications. At the time of this writing, Maven 2 is being used to handle library dependencies and create starter applications, like quickstart. Since our goal is to get you up and running with Tapestry, here are some hints to save you some time with learning Maven. For further Maven information see their website here: http://maven.apache.org/

If you are just using regular Eclipse, you can run

mvn eclipse:eclipse

and Maven will generate some files for Eclipse, so that Eclipse can recognize it as a project. It also helps Eclipse recognize that the library files your project uses are NOT in a WEB-INF/lib, they are in your local repository, which is ~username/.m2/repository

Eclipse WTP

Eclipse WTP is a version of Eclipse that is bundled with several complementing plugins for generating web applications. You don't have to use it, and many people use other IDEs or other bundled packages of Eclipse. Eclipse WTP has it's own version number, apart from the main Eclipse IDE at it's core.

There is a Maven command that will generate the files Eclipse WTP needs in order to open your project as a "Dynamic Web Project". Without those settings, WTP is pretty useless; you won't be able to add a server profile, set a web context, etc.

The command you will need to run is:

mvn eclipse:eclipse -Dwtpversion=1.5

Where 1.5 is the version of Eclipse WTP you are using. There are older version numbers you can put in, so search online if you need that. 1.5 should work for WTP 1.5.x.

Since this is feature given by Maven, make sure you check their documentation about what version number to use if 1.5 does not suffice for you.

*You will need to run this every time you change/add/delete dependencies in your POM.xml. This is because the command updates the dependency mappings that Eclipse will use for your project.

Tapestry5EclipseWTPWithMaven2 (last edited 2009-09-20 23:20:26 by localhost)